Home TECH Dropbox drops support for Android KitKat and Lollipop devices

Dropbox drops support for Android KitKat and Lollipop devices

by biasharadigest

Cloud storage service Dropbox will no longer support devices running older versions of Android, namely Android 5 aka Lollipop and Android 4.4 aka KitKat.

Starting with version v198.2.2 of its Android application, Dropbox is recommending that it be installed on devices at least Android 6.0, Marshmallow.

Android KitKat and Android Lollipop have been around for a while now. Going by the most recent Android platform distribution data that we have, just 4% and 9% of devices running Android are powered by KitKat and Lollipop, respectively.

As such, this news shouldn’t hit many users since these are old versions of Android that not many device users are still holding onto. Android Lollipop launched in its first iteration (5.0) about 6 years ago while Android KitKat, at 7 years, is even older.

For anyone who still has a device running KitKat or Lollipop, there’s nothing to worry about, at least for now. The Dropbox app available on those devices should continue working just fine. It’s only that there won’t ever be any new updates coming your way and that also translates to no new features. On the off chance that vulnerabilities in the app are discovered and patched, such users won’t be in a position to get any fixes. If ever there was a sign to upgrade, then this is it.


Related Posts

Leave a Comment